Hans Dulimarta

Android Maps API V2

I recently updated one of my Android apps to use the Android Maps API v2. The modifications required to the code base go beyond changing packages from com.google.android.maps to com.google.android.gms.maps. With the Maps client being part of the Google Play Services, any Android apps that use Google Maps v2 must be setup to use the Google Play Services library. In addition, the may also use a few utilities from the Android Maps Utility library.

The Google Play Services Setup instructions for installing the library on Eclipse, Android Studio (or gradle-based IntelliJ), but for IntelliJ users who transition from Eclipse, the instructions lack some details.

See the details in the video below: